Home

Share this Story

Download: Multi-Touch Keyboard from DROID X

That was quick.  Phone just got released to media members yesterday and someone has already started ripping goodies from it.  First up, the multi-touch keyboard.  Yay!

I was able to get this to work on my non-rooted Droid Incredible flawlessly and should also work on a 2.1 Droid.  With that said, I was unable to get it to work on my 2.2 Froyo Droid.  Apparently it will work with Froyo, but my JRummy’d version didn’t like it.

Video action…

Instructions…

*For all users.  Rooted and non-rooted.

1. Download this file to your SD card:  repackaged-signed.apk
2. Once it finishes, tap on it and then click “Install.”
3. When that finishes, exit out and go into Settings>Language & Keyboard
4. Check the box for “Multi-touch keyboad.”
5. Exit out and open a text box, long press and choose “input method.”
6. Select “multi-touch keyboard.”
7. Done!

Please let us know in the comments if you get this to work on a 2.2 ROM or stock 2.1 Droid.  Thanks!

And another big thanks is in store for the guys at XDA Forums for porting this over.  Amazing work again.

This has also been added to our downloads page.

Source: XDA Forums

Cheers Greg!

_______________________________________________

More Droid X Goodies: Multi-touch KeyboardBoot Animation | Wallpapers | Live Wallpaper

  • Brycecarlson98

    i can get it to install and select it in settings and go to messages or something and when i switch keyboards it force closes….. so close :/ htc sensation

  • Allstrchrgurl11

    why do we have to pay ?

  • http://twitter.com/MastaMarc Marc C.

    Can we get this in a zip? I like this one better than the gingerbread keyboard

  • Dudesky1325

    When i saw this was available i was really excited. I installed it but when i select it in the input method, no keyboard would come up, eris 2.1

  • Crawler2t

    doesn't work for 2.2

  • Crawler2t

    doesn't work for 2.2

  • Joeferb

    if you are rooted you can download it for 2.2 at http://www.droidforums.net/forum/cvpcs/70430-th… and flash it. its down a little ways and its called d2kb.zip im using it and it works fine. i dont know if it is 100% the exact same. works well though

  • Joeferb

    if you are rooted you can download it for 2.2 at http://www.droidforums.net/forum/cvpcs/70430-th… and flash it. its down a little ways and its called d2kb.zip im using it and it works fine. i dont know if it is 100% the exact same. works well though

  • White2007gt

    FC FC FC FC FC FC FC FC FC

  • ~~REAPER~~

    Droid Unrooted running 2.2, “stops unexpectedly” Force close.

  • lschicky

    Doesn't seem to work on offical Froyo :(

  • hickerbocker

    When can we get this on the MotoDroid with Froyo???

  • xmetl

    it doesnt work with froyo

  • Cscotina29

    it is a pretty sick keyboard, but what is the deal with the privacy and it being able to remember what is typed?

  • David

    put on stock Evo , no landscape now.

  • Scott

    The “&” symbol comes up as the html code of the symbol (“&amp”) and doesn't quite fit on the key when in portrait mode.

  • http://www.facebook.com/dlandons David Landon Smith

    After a few moments of unresponsivity, the key board popped up and it is amazing! Thanks guys, now if only we get that cool Magnification point from the DroidX and some of the Motoblur-style widgets.

  • twistedlim

    dropped in in my droid stock 2.1. Voice works, types nice, no vibrate. Warnings about source getting your text? Anyway, It triggered a blank screen, no apps on the page. Fiddled around and got it back but it seems to have some kind of bug for now. We'll try later but thanks for the info!

  • http://twitter.com/mrcamillo Peter

    Looks good, might have to try it!

  • Nate88music

    Does this work on any Android phone with 2.1?

  • SteeloDroid

    Works for non rooted 2.1 Droid! I'm loving it. Voice input works too

  • Se7h

    forecloses on buglessbeast v0.3…

  • Sda

    I had to download it twice for some reason, but it worked perfectly the second time. It does have the speech to text icon on handcent, and that's really the only time I ever use it. It will take a little getting used to, but the speed that I'm able to type on it is incredible. Now if I can just get my accuracy a little better.

  • Dsalinas1985

    worked on my droid 2.1 unrooted. just downloaded to on my comp then put on astro. installed and there it was..good to have…

  • 0101th

    Sweet works on stock Moto Droid 2.1, even the mic button works. Thanks!

    • 0101th

      BTW, if you want to use the multi-touch keyboard as default you can unselect the Android keyboard option under the Language & Keyboard settings and just select the multi-touch option.

  • RogMarn

    Installed and had no issues.. like it better than stock Android keyboard so far!

  • http://www.facebook.com/mmosquera91 Miguel Mosquera

    dd

  • http://www.facebook.com/mmosquera91 Miguel Mosquera

    Hey man, this is a NICE post, but after copying to the sd, when its “installing” it shows a screen saying that the aplication wasnt installed… I have a Motorola Milestone/Droid… Can u help me? :)

    • El Rafar

      Same problem here… Milestone 2.1

  • Alvinm 77

    On the keyboard my “&” button says &amp. No vibration when pressing keys and no swype. Its ok but could be much better. Going back to default but keeping it. Hope a better one come around ……….. Droid Incredible

  • Docism

    Works fine on 2.1 thanks.

  • Nate

    It really messes up the way messaging acts with android 2.1…Sends duplicate messages if you decide to use physical keyboard otherwise! :( i want it sooo bad

  • Jake

    it says that it's gonna replace another application. what's it gonna replace?

  • boyto2nice

    doesn't work on droid 2.2 :{

  • Kobeonradio

    I downloaded this and installed it fine. Works like a charm, only thing I noticed is that my Droid (2.1 unrooted) would reboot by itself, funny thing was when it rebooted it went blank, the eye came on and then went back to normal, usually when I boot up it takes a lil longer. This has never happened to me, was it because of the keyboard? I hope not since I loved the new keyboard (which I have taken off for now) Thanks

  • trombone dixie

    works perfect, thanks!

  • Foundabug

    FOUND A BUG IN THE KEYBOARD, SOMEONE FIX IT PLEASE:

    When the keyboard, on keypress when you press ?123 button the bottom left corner, there is a problem with one of the keys showing the correct display of a key… The key ” & ” is displayed as ” & ” in both landscape and portrait mode. Anyone have a fix for this so it just displays the ” & ” ?.

    -Forgot to mention that the above process was done using a Motorola Droid Rooted v2.1. Guessing the same problems/effects are the same on the incredible