Home

Share this Story

Play Store Update to 4.3.10 Causing “Package file is invalid” Error for Many During App Updates

google play 4.3.10

The newest version of Google Play (build 4.3.10) is apparently causing a number of problems for users who are trying to update apps. Both our comments and a variety of forum threads are filled with readers who are receiving a “Package file is invalid” error during updates. The error isn’t showing for all apps, nor have we been able to figure out a pattern. At times, the error presents itself with Google apps, while at other times they update fine. We’re also seeing the error for non-Google apps, but again, it’s tough to figure out why and when it will happen.

Feel free to weigh in if you are having any issues with 4.3.10.

As soon as we know a fix or hear something official, we’ll be sure to pass it along.

Update:  This is not guaranteed to fix you, but some have had success by going into Settings>Apps, clearing cache or data on Google Play Services, and then restarting their phones.

Update 2:  Some users are reporting that the issue showed up before the 4.3.10 update, so it could just be a general Play store issue.

Cheers Terry, BulletTooth_Tony, and everyone else!

  • Jordan Lee

    Just remove Google Account and add the google account again.

  • Rob

    No update issues here, checked for updates after I read this and had 6. all 6 installed without any issues. phones a moto razr max with avatar rom.

  • Bigsike

    Only happened to me with some Samsung apps, odd.

  • gfacekilla01

    I am so frickin’ sick of updates to the play store, and chrome and gmail and maps, every other day!!!! WTF are they doing?!?!?!

    • hkklife

      Nothing wrong with frequent updates…my beef is that the recent updates have been buggy! And I’m still not getting the new UI of Google Maps, FWIW.

  • Eric

    I’m on 4.1.6 and it’s doing the same for me…

  • Daniel Thomas

    I have the nexus 4 and this has been happening for a few days with multiple apps. What’s worked for me (more times than not) is switching from wifi to carrier data. I tried deleting the cache, like mentioned above, and that does not work either.

  • R

    Unlike other solutions that I have seen, this actually works: Follow the below simply step carefully to solve this problem
    1.download this VPN software(hideman)http://www.mediafire.com/download/4b5mato1mtb7vrk/net.hideman_2.1.apk
    Or you can still download any other vpn software that can change your ip but I used hideman

    2.After you have installed this software on your phone,open it and click on country of connection and choose United State then connect

    3. Now open your playstore and download any app

    • Chad

      This process works great, although it’s annoying that it’s necessary. Just upgraded to the LG Optimus G Pro Tuesday and it’s been like pulling teeth getting apps installed and updated until I used this process

    • imneveral0ne

      But I’m already in the United States…

      • R

        then you don’t have to change the country of connection

        • Gabriel

          Wait , how exactly do you install this on your phone? i downloaded it on my pc, and not sure if i need to put it on my device memory card and flash it or just download it from the browser on my device . and even then i don’t know where to go from there. please help

    • Colin

      WORKS PERFECTLY!

    • RadOD

      This worked for me!

    • ossito

      dude, this totally worked, thanks bro

    • Terrance G. McClary

      Thank you for sharing this solution. It worked for me!

    • Binky

      thank you thank you thank you!!!!!!!!!!!

    • WVOz1970

      Worked for me. Thanks for the VPN suggestion.

    • Jesse Carroll

      Tried lots of other stuff and this is the ONLY thing that allowed me to install/update anything.

    • Steven Buehler

      This worked for me perfectly. But why would this work for this problem? I tried different networks and even went to the AT&T store to have them figure out what was wrong. They tried on 2 of their wifi’s, plus 4G and 3G and still had the problem.

    • Tae

      Worked! Thank you!

    • Samurai

      Worked for “facebook package file is invalid error” ;) … THANK U

    • b

      works thank you thank you thank you!!

    • http://www.thewhitedoe.blogspot.com/ Ally

      Thank you SO much! This worked for the Instagram app!

    • Joe N

      Worked for me…I’ve read all these posts and this is the only thing that worked for me. I wanted my old version of RootCallBlocker Pro before it updated, without my permission of course, and luckily I had a backup with the older version. I’m running the FrostyJB rom, so then I installed it thinking that this back-up was made before the “Package file is invalid” error popped up and that would fix the problem..yeah right… just wishful thinking. Fresh rom install so all the caches and memory were empty… And because I’ve used the hideman VPN app so much, I ran out of free airtime and don’t see the point in paying for more just for a couple of updates. I don’t mind not having the latest updated apps, in fact sometimes I prefer the old versions. As many of us do I’m sure.
      So someone please figure out a “perm fix” for this, let google know, get job with google for finding “the fix”, rub it in everyone’s face, then quit new job with google (after winning sexual harassment suit) and live happily ever after knowing that you solved the great “Package File is Invalid” error of 2013.

      Or just post the fix so the rest of us can apply it…….the rest is just wishful thinking…:)

      Joe N.
      Little Rock

    • annoyed

      Worked like a charm. Just picked up a new Samsung Galaxy 4 and thought it wa the new damn phone. Tried all the other suggestions, clearing cache etc. Nothing worked until this. thanks!!!

    • REBobBecker

      Worked for me too. Brilliant!

    • Andrew James

      Worked for me too after trying everything else. Cheers!

  • Malcolm Love

    I think my Play app only updated last night, but haven’t had any problems, just updated about 5 apps actually. Side note question: What ever happened to Google’s “Delta” app updates? Did they ever roll that out? In the process?

  • http://www.vinsonimages.com yamaha83

    that moto X sure is good looking!

    • Schism

      it is starting to appear in a lot of thumbnails for articles involving the play store for some reason

    • Sean

      I drool every time I see it… Aug 23, aug 23, aug 23

      • michael arazan

        November, november, november, for us that want to customize it and create an etching on the back like andy taking a dump on the verizon logo

  • ed

    Market doctor on titanium backup fixes the issue.

  • Amanda Garrison

    This is happing to every one in my house hold including on my tablets and phones….VERY ANNOYING!

  • CharlieMikeDelta

    No issues here; stock GS4 on Verizon w/ Play Store version 4.3.10

  • Steven

    Nothing you can do will fix it. I’ve done factory reset on both my S3 and Nexus 7 (2013) and still get the errors sporadically. The one app that will not install whatsoever is Facebook Messenger. But virtually every other app out there gave me the error at least once, only to try again and it worked fine.

    • Steven

      Also, I’m still on Play Store 4.2.9, so its not a 4.3.1 issue.

  • Jamie

    I just cleared the cache in Google Play Services. Nothing else, no restart, and everything works fine now. I’m on a Galaxy Nexus on Verizon, Stock 4.2.2

  • 2Berad

    I have the Gplay update on gnex running CM10.1 and acer a510 running 4.1.2 no issues yet. have had several apps update since the play update without issue.

    • jessica702

      just as Elizabeth replied I didn’t even know that a stay at home mom
      able to make $7638 in one month on the computer. did you read this
      webpage w­w­w.K­E­P­2.c­o­m

  • Ryan

    No problems here. Updated the store then got the google books update fine.

    Maybe a network issue not the new store update…?

  • MildlyAmbitious

    In Regards to the “Update”, there is a thread on Reddit.com/r/android that states that reasons you DO NO want to do that. I am at work at the moment and would link if I could, but sadly we have Reddit blocked.

  • btstump

    Here’s what I did and it fixed the issue on my Samsung GS4, which I’d been having since yesterday:

    – Re-added Google account
    – Rebooted phone
    – Killed Google Services Framework, Google Play Store and Google Play Services
    – Rebooted phone

    Updated apps then and everything went great!

  • Daniel Clifford

    Getting error 497 here, nothing about invalid package.

  • Leif Sikorski

    I still have the old version. This is one of the reasons why I like the new staged rollouts.

  • Justin Rogers

    Happened to me on a fresh install of Android… Dont think the clearing a cache is going to help… Looks like a fix that needs to be done by Google

  • Nathan

    logcat is showing “Signature check failed, aborting installation.”. Some apps updated, others did not. Same issue on 2 different phones yesterday and today. My guess is that it’s a change in the Play Store where some apps are no longer valid.

  • ickyboo

    Ok, I’ve fixed my problem.

    I removed and re-added my Google account and now Play Store works perfectly.

    Settings/Accounts/Google/ then click on the account then Menu , then Remove account.

    Then add just add your Google account back again.

    So that might be a solution for you guys having issues.

    • Tyler Bell

      That’s a fix for some. I’ve done that 4 times today, along with clearing data and caches, but still getting the package file invalid alert.

      • btstump

        I posted this above. Try this, I tried all kinds of stuff on my GS4 and it didn’t work until I did this:

        – Re-added Google account
        – Rebooted phone
        – Killed Google Services Framework, Google Play Store and Google Play Services
        – Rebooted phone

      • aye_winchell

        i believe i had to clear data, force stop and clear cache on play services, google services framework and download manager, then remove and re-add my google account and that worked for me, after going through what you’re going through.

  • Guest

    what phone is in the pic? The X?

    • Nathan

      yep

  • Tyler Bell

    Happened to me before the update as well. I’ve had 3 apps (MapMyRun, a stock samsung app, and instagram) that have refused to update. I have a GS4 and this has been going on for about 4 or 5 days now. EDIT: Add Google Play Books to that list as well.

    • btstump

      Try this, my GS4 was having issues as well until I did this:

      – Re-added Google account
      – Rebooted phone
      – Killed Google Services Framework, Google Play Store and Google Play Services
      – Rebooted phone

  • dannydarko

    I was running MoKee rom on my D2TMO(GS3) and every app update didn’t work. I just flashed Liquid JB v2.9 and haven’t had any issues. Nice to know it wasn’t isolated to the rom or my handset as Mokee rom is a sweet rom as well as Liquid JB. I hope they fix it as it was a huge pain in the ass.

  • Kevin B

    I switched to a my first 4.3 ROM yesterday, and had this issue with a number of google apps, but I just thought it was because the apps were included as system apps in the ROM. I was able to grab them from the Play store after using TiB to uninstall them.

  • HellRa1SeR

    Was happening since morning. i though it was a problem with google servers. Instagram was not updating.

    But half an hour ago everything started working normal again.

  • Newge

    Received my new Nexus 7 yesterday. Many apps have downloaded fine but many have not. I have been receiving “Error 497″ and “Package File Invalid” errors since I plugged it in. Frustrating.

    • btstump

      Check out my post above.

  • chico

    Go into app manager and clear cache in Google Play app if you have a problem then try updating the app

    • EdubE24

      The Android “jank” strikes again!!

      • ReturnOfTheMack

        You keep using that word, but I do not think it means what you think it means.

        • EdubE24

          Let me take a stab at it. The glitchy screen action that happens on some Android devices. Things that are suppose to work smoothly not working as smoothly as possible.

          Two reasons my Note 2 was sold last week. How did I do?

          • Cora caroni

            Perhaps it’s user malfunction

    • taksgrv

      worked like a charm…thanks!

    • taksgrv

      worked like a charm…thanks!

      • takgrv

        oops…retract my last comment…it didn’t work. I was on the wrong device.

  • Damien Luna

    dumb question but what phone is that in the picture

    • http://www.droid-life.com Kellex B

      Moto X.

      • Damien Luna

        thank you kellex i thought it was but wanted to make sure. im with tmobile and the moto x may be my next phone im over specs and all about ease of use

      • ahhh yes

        thanks! i just asked before i read the posts…

  • OreoMan

    I’ve been getting this error message for the Firefox Android Browser update for a week now and I’m not even on 4.3.10 yet.

  • https://twitter.com/#!/doomstang Doomstang

    Happened to me yesterday for Facebook Messenger. I cleared app data on Google Play Store and Google Play Services….that seemed to fix it.

  • Zack Stewart

    Jetpack Joyride updated on my VZW Galaxy Note 2, My N7(2012 & 2013), my Asus Transformer TF700, my VZW Galaxy Note 10.1, NVIDIA SHIELD, Motorola Xyboard, and Galaxy Tab however after several attempts it will not on my HTC One Developer Edition, gives me the Package File is Invalid

    • borgey

      Its because you don’t own enough devices. Problem solved, no need to thank ,me

      • Zack Stewart

        Well three of them are company devices ;) so thats alot more reasonable… I do tablet support for my company so I have a bunch of devices to keep up with, plus Im just a tech geek…

  • DroidRockets

    Had issues yesterday, rebooted phone tried again, problem still there. Tried two hours later everything updated fine. No problems at all today?!?!? Galaxy Note II

  • Bob G

    Unrelated, but looking that close to the screen, amoled does not look pretty.

    • El_Big_CHRIS

      Yeah it’s true, but some people here will take offense to this lol

  • Mjailme

    Happen to me this morning. Had to delete google account from my s3 and then add it again.

  • Sean

    Clear cache. Works like a charm.

  • Justin Brock

    I was wondering what the deal with that was. Been getting it ever since I got my HTC One on Monday.

  • jbegs

    Had this issue this morning on my Verizon (boo) GN2 trying to update Instagram. It failed 3 times. I turned my WiFi off and the app updated in mere seconds.

  • Brady Wassam

    Updated netflix vine and twitter. Only twitter failed

  • gsDroid

    Same problem here, just started today. I have cleared cache & data in Play Store, Play Services, Download Manager, deleted and re-entered Google account, cleared cache and dalvik, and restarted a couple of times. I still get the error.

    • http://twitter.com/jdrch jdrch

      Same here.

    • indy500

      Same here.

    • ashley

      I deleted everyting restarted nothing then turnedboff wifi and 4 g worked let me update and download apps

    • evilpizzaguy44

      Same

  • bkosh84

    It actually started happening before this update.. I didn’t get an update and sideloaded the new Play Store to my phone to get it so it was happening before 4.3.1 came out.

    • bkosh84

      Just to be clearer.. I sideloaded the update this morning and I’ve been having the “Invalid Package Error” since yesterday morning.

      • El_Big_CHRIS

        Yeah same here. I don’t know if after this update it does it more, but I’ve gotten that error a few times after the new new UI update

  • http://www.coroflot.com/mellerad Adam Meller

    Vine and Facebook Messenger both failed updates for me.

  • Will Carter

    Had this happen to me a few times. Got around the error I was having with Samsung app on my GS3 by updating over 4G instead of wifi. Dont’ know if that helps with other apps but it worked for me.

    • Meltdown07

      I was able to get some apps on my GS4 to update the same way, but not all of them were able to be fixed this way. What a pain

      • btstump

        Check my other post. I have a GS4 and was able to fix it.

      • RLJSlick

        Work for me too, thanks

    • fireworksordie

      worked for me this way.

    • Executor

      This happened to me before I got the Play Store update on my GNex. Netflix updated fine, but AirDroid and a few other apps would not. I did the same thing you did to fix it.

    • woodraskam

      Had this happen to my GS4 after rooting it. The fix I discovered was to sign into a second google account on the phone, and then sign back into your main account. Afterwards you can delete the secondary account.

      • Aleksandra Huey

        that worked for me too

      • vyduxawanuxe

        мy coυѕιɴ ιѕ мαĸιɴɢ $51/нoυr oɴlιɴe. υɴeмployed ғor α coυple oғ yeαrѕ αɴd prevιoυѕ yeαr ѕнe ɢoт α $1З619cнecĸ wιтн oɴlιɴe joв ғor α coυple oғ dαyѕ. ѕee мore αт…­ ­ViewMore——————————————&#46qr&#46net/kAgk

        Was wondering what the deal was..
        Seems to have been fixed though, both MX Player and Netflix updated
        just fine today after giving errors on both my phone and tab yesterday.

    • Zomby2D

      Worked for me too. Was finally able to update Instagram by flipping Wi-Fi off.

      It’s not the first time I get that particular error but usually I just need to update the app one more time and it goes away.

      • BrandonP

        lol exact opposite for me. I turned wifi on and it started working. Weird.

    • http://www.chambanachik-live.blogspot.com/ chambanachik

      Also worked for me. Thank you!!

  • http://www.gadgetsteria.com The Gadgeteur

    Had this issue when trying to troubleshoot an issue with Cyanogenmod ROM. Go to Settings > Apps and clear data on Google Play Services then restart your phone. It’s not a sure fire fix but it helped me. One other thing to try is uninstalling play store updates, clearing the data for it and restarting your phone.

    • aye_winchell

      I had an issue a couple weeks back before and after 4.3 (tired updating to see if that would fix it, it didn’t) i did all of the things you did and it didn’t work, until i did those AND removed my google account, added it back and rebooted, since then everything has been fine.

      So if this doesn’t work try again only remove and re-add your google account too.

      To be clear this wasn’t just apps not updating, i couldn’t install anything, everything gave me the package error.

      • http://www.gadgetsteria.com The Gadgeteur

        Yeah. By the time mine finally started working it was after several different ROM flashes from scratch. But after I was in a ROM for a bit I did the data clearing on play store, play store services and for hell of it, play services framework and rebooted and it finally started working.

        • aye_winchell

          I couldn’t believe that it didn’t fix it after i upgraded to 4.3, i thought i was losing my damn mind.

  • brkshr

    I haven’t had any problems on my N4 & N713

    Edit: CM10.1 on the N4 & Stock on the N713

  • Peter Blanco

    Yup, definitely having this problem.

    • btstump

      Check my post above. I have a GS4 and the only thing that worked for me were the steps above.

      • Gmac

        I tried the steps you provided on my note 2 and it still gave the error. oh well im not going to worry about it if they want to fix it so be it if not no biggie.

  • Mike

    I’ve Been having this problem, tried to download Netflix and this happened. Along with some Samsung apps – Galaxy S4

    • btstump

      I have a GS4. Look at my post above for fix.

  • mustbepbs

    Seems like par for the course when it comes to Google.

    • btstump

      Apple troll. Move on. Nothing to see here.

      • mustbepbs

        Apple troll? Really? You must be new around here.

        • daddytj

          Apple fanboy at least. Ive been an android user for a year so ffarcrom apple previously. Love my note 2. Never had issues like this in the past with anxroid

          • mustbepbs

            I own exactly zero Apple products. In fact, I’m a staunch opposer of them at my PC repair shop due to their anti-consumer nature of proprietary parts.

            Look at me, I’m arguing about my “allegiance” to consumer product brands on the internet.