Home

Share this Story

Google Changes “Package File Invalid” Issue Status to “Resolved” – All Good on Your End?

SONY DSC

This morning, Google changed the status of the  “Package File Invalid” issue that was plaguing app updates to “resolved.” We first reported on this issue last week, around the time that the new Play store 4.3.10 started to rollout, before Google acknowledged it yesterday. At least one reader of ours stopped by our inbox to let us know that the issue has been fixed on his end.

So we thought we’d ask the rest of you – still seeing errors or is your Play store back to normal?

Via:  Google Support

  • Jimmy Giggly
  • jeesung

    Just restored a Nandroid from last week on one of my tablets and more than half the apps that needed updates failed with “Package file is invalid” :(

  • jeesung

    Just got one w/ Google Translate update. I’m on Play Store 4.3.11
    First one in 2 days so may be isolated.

  • Ralph Basile

    Yes. All good now.

  • sagisarius

    Fixed on all my devices!

  • diversion

    I was getting the package file invalid error yesterday when trying to download the Portal app that was featured here. Now, even after clearing data and forcing it to stop like the rude user below suggested, I’m getting a different error. See screenshot.

    • gorkon

      I think the “fix” is what causes this error. This happened to me when I tried to fix it myself. I even reset my phone to no avail….but that message went away. The invalid package did not.

  • Guest

    I’m still getting a 403 error when trying to download the PowerAmp unlocker I paid for.. sigh.. That seems to be the only app not working.. Must be a dev issue..

  • Jorge

    I only had the issue on the first day that the update installed, now I’m just annoyed by the “recently updated” tab that displays apps for much longer than “recent” would imply

  • johnediii

    I was having this issue for Netflix and Twitter and couple others updating on my Nexus 4 and Nexus 7. This morning I noticed some notifications when I woke up and it was the successful update of all of the ones that weren’t working.

  • stabone

    Mine’s never updated past 4.1.10

  • Mike

    I only had this problem with my Galaxy S4 updating Samsung apps, but yes its working now.

  • zapote21

    Hmmm Never had an issue. Been updating just fine

    • JoshGroff

      I had the issue when batch updating, but manually updating the apps 1 at a time fixed it.

  • Roguefort

    Hey look! the Moto X is the Main picture for the article!

    • Munchma Quchi

      ________________________________________________________________

  • terry12s

    Yup, it’s resolved and working for me. I had trouble with it for two weeks but it’s working on both my Gen 1 &2 Nexus 7′s now.

    • DroidzFX

      One for each hand?

      • terry12s

        Haha, I bought the new one because my 11 year old daughter has taken over my 1st Gen Nexus 7.

    • Roguefort

      you use two Nexus 7′s?

      • Raven65

        Some of us have significant others.

        • Roguefort

          ok but he said “both my Gen 1 &2 Nexus 7′s” meaning they are his.

          • terry12s

            Ya, I consider both of them to be mine since I payed for them but my daughter completely hogs my 1st Gen Nexus 7.

          • Sirx

            That’s adorable! Not sure why you got three downvotes on your initial post, though :-/ The Droid-Life crowd is a strange and fickle lot…

          • Guest

            Haha, yes they sure are, oh well :)

          • Roguefort

            that makes sense.

        • terry12s

          Or daughters :)

  • BenderBendingRodriguez0101001

    I was on 4.3.10 since the apk was released and never encountered this issue. It was reported a lot over at XDA though. Noobs were blaming the rom they were on.

    • https://www.facebook.com/aaron.williams.125 Champion1229

      I think it was more to do with what connection you were using. I’ve always used mobile data and have never had an issue but a lot of people have been having issues with updating on WiFi.

      • Justin W

        I noticed the issue last night when trying to download an app via WiFi, but I switched to mobile data and had no issues.

  • TruthHurtsTheIgnorant

    Before you idiots start posting “It isnt working for me” make sure you FORCE STOP PLAY STORE and CLEAR DATA.

    • j__h

      Not force stopping and clearing data does not an idiot make.

      • DroidzFX

        yeah what he said.

    • Derek Duncan

      ok i’ll go tell my mom, she knows what that means…

    • gorkon

      How about….rebooting your phone. That is something everyone understands….even noobs.

    • NexusPhan69

      This is what caused the issue in the first place!

  • Bill Hill

    idk about that but I just saved a bunch of money on my car insurance by switching to geico

    • JoshGroff

      Completely unexpected, have an upvote.

      • col3rsc

        I currently have Progressive and I will probably stay with Progressive in the future but you should get Geico.

        • Mike

          Ha! Up vote for you.

        • JoshGroff

          If I wasn’t at work, I’d be laughing so hard right now. Well played.

        • michael arazan

          Just made Peking Duck from Aflack, poor guy didn’t make it, but was quite tasty