Home

Share this Story

File Found to Fix Jelly Bean ROM WiFi Problem, Flashable Through CWM Recovery

One thing you may or may not have noticed after flashing one of the Jelly Bean builds for your phone yesterday was that the WiFi performance seemed to be lacking a little bit (for example, when JB is flashed onto the Verizon Galaxy Nexus). Places where you would normally have a full signal were only coming up as a few bars instead. XDA member mwalt2 had enough and found the resulting different WiFi file in his Ice Cream Sandwich ROM, applied it to Jelly Bean and voila! WiFi that’s back up and running at top speed.

After downloading, the file can be flashed through ClockworkMod Recovery and while mwalt2 suggests a cache wipe may be needed, many people are reporting that a straight install works as well. It’s always good to make a back up!

Via: XDA

  • ddevito

    If I go from Vicious V1 to V2 do I need to wipe everything again?

  • fvqu

    I’ve had my phone freeze on my once since installing Jelly Bean while on the lock screen. I’m running v5. I hope this gets fixed soon.

  • James Hill

    Does anyone have a fix for Foxfi in JB?

  • http://twitter.com/badassbosoxfan ronald bernard

    I am having issues with the camera since flashing JB. It will not save pictures. Anyone else experiencing this? If there is a fix please let me know.

  • Jon Wright

    GPS needs a mwalt2 treatment. Modding the gps.conf helps some but it appears a-gps isn’t working properly.

  • ddevito

    Running Vicious V1, downloading V2. I manually patched the WiFi fix (no wipes needed) and changed my eri.xml to get my carrier branding back. Anyone notice any other differences with V2 vs. V1?

    • JermaineFerrell

      how did you change ur eri.xml?

  • Philip A. Kaiser

    Not to swing topics but does anyone know of a workaround for the hotspot issue? Foxfi is nogo.

  • adam1982

    The only bug I’ve noticed on Vicious V2 is when receiving or sending a picture message the data connection cuts out for a second or two.

  • http://twitter.com/Defenestratus Defenestratus

    I’m running vanibean v3 and tbh, I think I might go back to ICS. As much hoopla there was about how smooth it is, I think ICS was smoother. The notification window pulldown is slow (looks like three frames total) and switching between homescreens seems clunkier.

    • you know

      You can count frames? Thats like a super power.

  • Vantucky

    Axiom Flow has always had wifi working… and beats audio ;)

    • SeanBello

      can that Beats be ripped from the rom?

    • sc0rch3d

      droidhive ftw — still rocking b1ack adv 9 until DT makes some further refinements from cmplx into his JB build. :)

  • http://twitter.com/myermenson Michael Yermenson

    No wifi issues found, but latitude friends not showing up, anyone have similar issues? Also, in Google Now, the teams are not saving. Other than these 2 issues, JB is totally awesome!!
    Problem with latitude solved, http://forum.xda-developers.com/showthread.php?p=28013175

  • Tuna

    What rom is the best to go with right now?

    • AnotherAndroidKid

      I went with VanirBean v3. There was back and forth all day so far over whether to upgrade to v5. I am holding off just because i have to go out after work for the evening and don’t want to mess further until i can be home.

      No issues i’ve found with v3, although i’ve not navigated yet. i will in a couple hours. luckily my wife’s rezound is backup for that if this fails for me.

    • Larizard

      i have the same question. I’m ready to jump on this today, but deciding which rom to go with.

  • http://twitter.com/Bhockey77 Court

    I’m on Vicious V2 and the market keeps force closing after a few seconds. Anyone having a similar problem? If it matters i’m restoring through titanium right now.

    • SeanBello

      shouldn’t restore system apps since it’s different in JB. GAPPS are included.

      • http://twitter.com/Bhockey77 Court

        I wasn’t restoring Gapps… just my downloads.

    • jonny6pak

      I”m using Vicious V2 also. I had moved a couple apps I restored via TB over to the system location and that screwed up the market hard. I also restored some settings in TB that messed things up. I eventually started over, I let Google restore everything, then in TB I restored all my app data and all my missing apps (with their app data too). I rebooted and then restored only my wifi settings, bluetooth pairngs, SMS history, and nothing more. I manually set everything else up including accounts. It’s working perfectly now. I’m not sure how much of that process is actually necessary, but it worked. I’m loving JB right now.

    • PC_Tool

      Don’t restore…anything.

      It’ll suck, but start over from scratch and set it up like it was the first time. Also, do not let Google restore apps (you have the option to disable during OOB setup – uncheck them).

      Should run flawless at that point. Just takes a while to get the apps back up and running manually.

  • Pdiddy187

    Running VanirBEAN v3 and the only issue I have is having to do a battery pull occasionally on restart.

    • http://twitter.com/fiveomustang Brian Remick

      I’m seeing the same thing. Took me a couple battery pulls on reboot to get it up and running

  • eddieonofre

    now all I need is a galaxy nexus

    • PC_Tool

      I was jealous of my wife getting the SIII until I got JB on my Nexus.

      Now? Meh…who needs it. (Though I can’t even begin to imagine how well JB would run on the SIII…)

      No doubt I’ll be jealous again when JB AOKP gets ported to the SIII (it will happen…)

  • Jwhap

    I am running varibean v5 and no issues at all!

    • TheDrunkenClam

      Did it fix the pull down bar to say Verizon instead of cdma ???

      • Jwhap

        Yeah, that is fixed as well….guess I did not notice…..lol any place I can see less of Verizon’s name, I am game!

  • brkshr

    Or download one of the two ROMs on Rootzwiki

  • Greyhame

    This just crushed the last thing holding me back.. flashing JB tonight .. too many awesome improvements to ignore!

    • billy routh

      be carefull most people are having trouble booying back up after a second reboot

      • snowblind64

        No.

        What happens is that it sometimes stays at the “Google” screen for a couple minutes. It always boots for me.

        • michael arazan

          Just out of curiosity is there a youtube video for noobs to flash jellybean to their toro model gnex? I don’t think I want to wait 6 months for verizon again.

      • http://twitter.com/zachvossdesign zach voss

        yeah it took about 5 minutes on the boot screen for me, just wait it out, it will work :)

  • http://twitter.com/thehammerofthor Jeff Helget

    I’m running JD’s VanirBean V3 and it’s working flawlessly (I think this wifi fix is included in it… GPS works fine too)

    No complaints at all. I LOVE JELLY BEAN!

    • Jwhap

      Check your GPS tracking if you are having issues download the newest version. I did not notice this until I went to navigate this morning…..doh!

      • KenBarnum

        Can you just flash the new version over v3? I don’t want to redo my home screens!

        • Jwhap

          You have to wipe data and cache. You would have to redo home screen.

          • KenBarnum

            I got a tip from someone else that I could just wipe cache and davlik. I tried and it was successful. Did not have to redo my home screens.

          • Jwhap

            Nice!!!! Good to know…..I could have saved myself like two hours yesterday! Lol..

  • SirSoloDolo

    As much as I really want jelly bean, Sometimes you gotta let the flower bloom before you go ahead and chop it off

    • craig1989

      its bloomed, I dont see any bugs at all. Wifi seems to be the only possible culprit and thats now fixed

    • PC_Tool

      Consider it bloomed.

      Factory reset
      wipe dalvik
      format system
      flash JB.

      I have yet to see any reported issues on this when these steps are followed.

      I am personally running V2 of DroidVicious’ Liquid JB zip. Everything is working.

      (I will likely not be “upgrading” to any of the newer builds with scripts, modded kernels and such…IMO, JB doesn’t need any of that.)

      • http://twitter.com/patfrank Patrick Frank

        how do you format the system? i did a clean wipe from pete’s and now i can’t make backups with cwm. i’m thinking i need to format system.

        • PC_Tool

          Formatting system removes the ROM itself. Most rom-scripts do this “automagically”, but….

          To format system, boot into recovery and go to “mounts and storage”.

          From there you should be able to format system…just don’t reboot until you have flashed a ROM.

          If you’re going to have another go at it, start from scratch, with the Factory reset first.

      • http://www.facebook.com/exceter Mondrian Hernandez

        I was running Vicious v1 and did notice the Wi-fi. Within a matter of 4-6hrs, he cranked out v2. Everything is smooth as butter, just as described!

        The stock JB kernel makes my Nexus feel like a friggin Quad-core!

        • PC_Tool

          Bingo. V2 is the shiz.

          • http://twitter.com/Bhockey77 Court

            My problem w/ V2 is that it isn’t making a google data connection (whatever they call grey bars). Do they have a fix for this?

          • PC_Tool

            I’ve not had that specific problem.

            How did you install and are you working with the VZW Nexus?

    • http://twitter.com/GRZLA Grizzly Atoms

      I don’t understand why people are saying this. I get that SDK ports are terrible, but this a port based off of an actual OTA. If you own a Galaxy Nexus, then this thing runs perfectly.

    • richcricketz

      You have a whole garden of flowers, if you chop this one and it sucks then go chop another. I love seeing little JellyBeans growing in my garden and i’m not gonna wait to start picking them!

  • http://www.youtube.com/kimirPORTALS kimir

    “This was pretty simple. I just searched for wifi in the IMM76K verizon ROM, found a file called bcmdhd.cal that was different from the version in the Jellybean rom I was using (looks to be verizon specific), and pushed it to my phone. I wiped caches, but I am not sure if that was necessary. No need to wipe .” – you don’t need to wipe

  • http://twitter.com/Defenestratus Defenestratus

    BTW this isn’t needed in v3 and above of the JellyBean ROM linked yesterday.

    • skubadoo

      I can’t find v3, link?

  • http://www.youtube.com/kimirPORTALS kimir

    I use TWRP. Is that cool with this zip?

    • John

      Yep.

    • r0lct

      I used it and it worked.

    • http://twitter.com/GRZLA Grizzly Atoms

      I noticed a lot of the people who had issues flashing JB were on CWM. I personally use TWRP and have never had an issue flashing the things they label as CWM recommended. I noticed a lot of people using CWM also could not restore backups and had to completely return to a stock image and reroot and unlock bootloader.

      VanirBean v5 on Rootz has this fix built into it.

      • http://twitter.com/patfrank Patrick Frank

        good to know, as i said above i had problems backing up JB because of the CWM issues you reported. i’ll jump back to pete’s 4.0.4 and flash v5 and hope that works.